Elementor Templates

This topic contains 23 replies, has 3 voices, and was last updated by  Dave 4 years, 1 month ago.

We have moved to a support ticketing system and our forums are now closed.

Open Support Ticket
  • Author
    Posts
  • #540333

    Dave
    Full Member
    Post count: 205

    This is a really great development guys! Thanks.

    Is it possible now or in the future to create templates for certain packages i.e. Featured listings have their own design?

    Also, I’ve created an event details page, set the conditions to apply to all event post types, but it won’t work. Do I need to have all 3 templates setup and activated to get it working?

    #540349

    Alex Rollin
    Moderator
    Post count: 27815

    As you probably noticed it is not possible to assign a theme builder template based on price package, but you can do it by category, so, if your price packages have a unique category, then, listings with that category can have a different template.

    Did you create the template with the theme builder? You should not need anything more than that.

    If we need to check the settings please share credentials in a private reply AND a link to the WP Backend edit page for the template so we know where to look.

    WordPress Credentials
    WP Admin Login URL:
    WP Admin Username:
    WP Admin Password:

    #540352

    Stiofan O’Connor
    Site Admin
    Post count: 22956

    You can also use CSS class on any field or section and using the dynamic field use the GD CSS Hide condition, you can then set things to hide for specific things like if a package ID= x or does not equal x.

    (video coming tomorrow on Dynamic fields and CSS Hide conditions)

    Thanks,

    Stiofan

    #540354

    Dave
    Full Member
    Post count: 205
    This reply has been marked as private.
    #540355

    Dave
    Full Member
    Post count: 205

    Also just going back to your point Alex about assigning a package to a category, is that possible? I’d love to do that.

    Thanks,
    Dave

    #540370

    Stiofan O’Connor
    Site Admin
    Post count: 22956

    You had set a custom template in the standard events details page which was taking priority, when i set that to default it now shows the elementary template.

    Thanks,

    Stiofan

    #540378

    Dave
    Full Member
    Post count: 205

    Ah I see. Ok thanks Stiofan.

    For some reason, the main featured image isn’t showing though. It does when I’m editing it in the theme builder within elementor, but not on the live listings i.e.

    https://whatsonhub.com/events/united-kingdom/east-riding-of-yorkshire/the-woman-in-black-18/

    Any ideas?

    Thanks,
    Dave

    #540382

    Stiofan O’Connor
    Site Admin
    Post count: 22956

    Hi Dave,

    By default (now changed) we used to hide the featured image as some themes would add an extra big header.
    (i have done this for you now)
    Go to GeoDirectory >Settings > Design > Details > Disable theme feature image output? and untick.

    Stiofan

    #540395

    Dave
    Full Member
    Post count: 205

    Got it. Thanks again for your help.

    #540446

    Alex Rollin
    Moderator
    Post count: 27815

    To apply a template based on category based on price package, in your package settings make sure that a ‘free’ package has an excluded category like ‘PREMIUM’ – then make sure that category is included for the premium price package. Then set your special premium template to display when the place category is ‘PREMIUM’

    You might also make a note in the category field description like “Premium listings can take advantage of our super duper advanced SEO template by choosing the category ‘PREMIUM’ “.

    #540588

    Dave
    Full Member
    Post count: 205

    Ah I see. Thanks Alex. So the package can’t select the category automatically?

    #540645

    Alex Rollin
    Moderator
    Post count: 27815

    No

    #540653

    Dave
    Full Member
    Post count: 205

    Got it. Great suggestion on asking them to do it manually though. Thanks for your help.

    #540672

    Dave
    Full Member
    Post count: 205

    Sorry guys, I have another problem. This time, I’m trying to set up the event archive and archive items. However, it’s coming up with an error “post ID is missing” when trying to populate the listings with the archive item…

    https://whatsonhub.com/events/category/theatre-shows/united-kingdom/east-riding-of-yorkshire/

    I set up a second archive item template called “event archive 2” as I thought maybe it was an error in the first one I created (event archive item). But it’s still not working.

    I’ve changed it back to default in the event settings archive item thinking it might be the same error as yesterday.

    Can you help please?

    Thanks,
    Dave

    #540702

    Alex Rollin
    Moderator
    Post count: 27815
    This reply has been marked as private.
Viewing 15 posts - 1 through 15 (of 24 total)

We have moved to a support ticketing system and our forums are now closed.

Open Support Ticket