Linked CPT does not work

This topic contains 4 replies, has 2 voices, and was last updated by  Alex Rollin 2 months ago.

  • Author
    Posts
  • #483117

    fws2016
    Full Member
    Post count: 32

    Hi,

    I have a V1 GEO with EVENTS addon that has has been upgraded to V2 on a staging server. We used to have a custom code to link the events to places and restaurants but since the V2 now natively supports this we have removed the custom code and rely on the core to provide this functionality.

    Additionally we have also setup a new installation of the V2 with the sample data.

    Link post for other CPTs have been added to the event under “List of fields that will appear on add new Event listing form”

    The problem:
    Add event listing does not find the any listings when using ajax search with linked CPT. This works fine on the stock installation. None of other linked CPTs would work.

    With chrome code inspect in the network section I can confirm that the ajax search runs but does not return any values:

    Header tab shows:

    Request URL: https://ww1904.****.ca/en/wp-admin/admin-ajax.php
    Request Method: POST
    Status Code: 200 OK
    Remote Address: ******:443
    Referrer Policy: no-referrer-when-downgrade
    Access-Control-Allow-Credentials: true
    Access-Control-Allow-Origin: https://ww1904.****.ca
    Cache-Control: no-cache, must-revalidate, max-age=0
    Connection: Keep-Alive
    Content-Length: 2
    Content-Type: application/json; charset=UTF-8
    Date: Fri, 26 Apr 2019 19:22:32 GMT
    Expires: Wed, 11 Jan 1984 05:00:00 GMT
    Keep-Alive: timeout=5, max=100
    Pragma: no-cache
    Referrer-Policy: strict-origin-when-cross-origin
    Server: Apache
    X-Content-Type-Options: nosniff
    X-Frame-Options: SAMEORIGIN
    X-Powered-By: PHP/5.4.16
    X-Robots-Tag: noindex
    X-XSS-Protection: 1; mode=block
    Accept: application/json, text/javascript, */*; q=0.01
    Accept-Encoding: gzip, deflate, br
    Accept-Language: en-US,en;q=0.9
    Connection: keep-alive
    Content-Length: 95
    Content-Type: application/x-www-form-urlencoded; charset=UTF-8
    Cookie: wordpress_sec_f0c67f9cba178917588b201216746f50=****%40yahoo.com%7C1556318539%7CUili66WYuhuqfHZEZd25azCLmKtwkTFSnj5Ofj8ulK4%7Cb18d87b2b70bc2a0340755599d39c42f6aeea569698f6e40cea7bac0f7396d7f; wordpress_test_cookie=WP+Cookie+check; wordpress_logged_in_f0c67f9cba178917588b201216746f50=****%40yahoo.com%7C1556318539%7CUili66WYuhuqfHZEZd25azCLmKtwkTFSnj5Ofj8ulK4%7C553262babd1eaf3e0de337b178bf21bf8b4ca2d9903ff66d7d4aa8f607ddbafd; _ga=GA1.2.1962724914.1534364206; PHPSESSID=4oovhasr4jmtdr6rfbh7ctahg6
    Host: ww1904.****.ca
    Origin: https://ww1904.****.ca
    Referer: https://ww1904.****.ca/en/add-listing/?listing_type=gd_event
    User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/73.0.3683.103 Safari/537.36
    X-Requested-With: XMLHttpRequest
    term=so&action=geodir_cp_search_posts&source_cpt=gd_event&dest_cpt=gd_place&security=2797a379d5

    Response tab shows:

    []

    Wordpress debugging has been enabled and nothing shows there. I appreciate any assistance you can offer.

    Thanks

    #483128

    fws2016
    Full Member
    Post count: 32

    A valid licence is required to view this reply.

    You may need to login

    OR

    Buy either a Membership or valid licence for this product.

    Thanks, Team GeoDirectory!

    #483200

    Alex Rollin
    Moderator
    Post count: 18282

    A valid licence is required to view this reply.

    You may need to login

    OR

    Buy either a Membership or valid licence for this product.

    Thanks, Team GeoDirectory!

    #486733

    fws2016
    Full Member
    Post count: 32
    This reply has been marked as private.
    #486839

    Alex Rollin
    Moderator
    Post count: 18282

    A valid licence is required to view this reply.

    You may need to login

    OR

    Buy either a Membership or valid licence for this product.

    Thanks, Team GeoDirectory!

Viewing 5 posts - 1 through 5 (of 5 total)

The topic ‘Linked CPT does not work’ is closed to new replies, this may be for inactivity, please open a new topic if you have a similar question.