Add Event Calendar Page Displays Incorrect Date

This topic contains 7 replies, has 3 voices, and was last updated by  Kenneth 3 days, 17 hours ago.

  • Author
    Posts
  • #503004

    Kenneth
    Full Member
    Post count: 47

    I’m running GD V2 with Supreme template. Since the upgrade to V2, when adding an event, the calendar now comes up one day behind. Basically, today shows yesterday’s date. How can we fix this?

    Note: The date and time in the WP General Settings are correct.

    #503007

    Kor
    Moderator
    Post count: 13458

    Hi Kenneth,

    Thanks for your post. Kindly share the URL of the page in question so that I could check on it. Also, share your Website WP admin access here in private reply.

    #503078

    Kenneth
    Full Member
    Post count: 47
    This reply has been marked as private.
    #503079

    Kenneth
    Full Member
    Post count: 47
    This reply has been marked as private.
    #503089

    Kenneth
    Full Member
    Post count: 47
    This reply has been marked as private.
    #503104

    Alex Rollin
    Moderator
    Post count: 19417

    This looks to be due to the timezone of the site. New business hours are being added as timezone -5. You can see that setting in the add listing page when you open up the business hours.

    It is -5 because the site timezone is 4 hours off, and in daylight savings.

    The developers will take a look and clear it up for us. Thanks for your patience as it is currently a holiday period.

    In the meantime, have you considered changing the timezone so you can see how the business hours offset changes?>

    #503109

    Kenneth
    Full Member
    Post count: 47

    Thanks Alex, I hadn’t tried doing a timezone change. We’re on U.S. EST (i.e. New York) and I was thinking about that as well with the -5 but could not see where else that setting would be. The General/Global setting is set to N.Y. timezone and everything else was picking up the correct date.

    We did have this issue once with GD V1 but you guys fixed that and it worked fine afterwards.

    Thanks again and enjoy the holiday!

    #503111

    Kenneth
    Full Member
    Post count: 47

    Okay, just switched from New York Timezone to UTC-4 and it appears that may have corrected the issue. You guys can still check to confirm.
    Thanks

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.