Creating a new custom post type, bug

This topic contains 21 replies, has 3 voices, and was last updated by  Tony Mattioli 7 years, 9 months ago.

We have moved to a support ticketing system and our forums are now closed.

Open Support Ticket
  • Author
    Posts
  • #10636

    Tony Mattioli
    Expired Member
    Post count: 58

    I was adding a new custom post type, and after saving the settings to create it, all post types disappeared, place, events, ….

    Can you have a look to see if you can find a quick fix.

    Credentials will follow

    #10637

    Tony Mattioli
    Expired Member
    Post count: 58
    This reply has been marked as private.
    #10638

    Guust
    Moderator
    Post count: 29970

    What’s the URL, Tony?

    #10639

    Tony Mattioli
    Expired Member
    Post count: 58
    This reply has been marked as private.
    #10640

    Tony Mattioli
    Expired Member
    Post count: 58

    BTW, the version is not up to date yet because I did a lot of custom coding.

    #10642

    Guust
    Moderator
    Post count: 29970

    We’ll need your phpadmin too, and maybe FTP.

    #10645

    Tony Mattioli
    Expired Member
    Post count: 58
    This reply has been marked as private.
    #10646

    Guust
    Moderator
    Post count: 29970

    Did you by any chance use a non-standard character, like a french character when creating the new CTP?
    Vikas will take over from here.

    #10647

    Tony Mattioli
    Expired Member
    Post count: 58

    Yes, but not in the ctp name or slug, just in the description fields.

    Thanks for your quick response.

    #10650

    Vikas
    Full Member
    Post count: 1128

    Unfortunately u have lost all CPT related info, if u have inserted special characters there.

    How many CPT were there aside of place and event?

    #10651

    Tony Mattioli
    Expired Member
    Post count: 58

    There were two other cpt, artists and festivals. The tables are still in the database.

    I am more concerned on getting back the 10 entries then the cpt settings, because the later can be set back manually rapidally.

    Any suggestions to recoup.

    Thanks

    #10652

    Vikas
    Full Member
    Post count: 1128

    Listing will be restored automatically if u will create CPT with same slug.

    I am looking into a way to restore default CPT and a permanent solution for it, in mean time just recreate those CPT.

    Thanks

    #10653

    Tony Mattioli
    Expired Member
    Post count: 58

    ok, thanks. I will do that.

    #10654

    Vikas
    Full Member
    Post count: 1128

    Thanks so much, i will find a permanent solution for this problem tomorrow

    #10764

    Vikas
    Full Member
    Post count: 1128

    Hi,
    Please let me know if u have added those CPT again?
    I have fixed this issue permanently. I just need ur assistance to check if its working fine. I have checked it my end, but it would be good if i get confirmation from u that things are working fine even if u enter same french values again.

    Steps to take backup of CPT settings:

    To take backup of that option, go to phpmyadmin of the WP database , run this sql to get the particular option row in database.

    SELECT * FROM wp_options WHERE option_name LIKE '%geodir_post_types%'

    After this u will see specific record, just edit it and copy the big textarea text somewhere else, this way u have taken backup of all current CPTs settings. Have a look on attached image for more clarification about backup.

    Now just extract attached zip, upload these 2 php files in Custom post type ad-on folder using FTP.

    Thanks
    Vikas

Viewing 15 posts - 1 through 15 (of 22 total)

We have moved to a support ticketing system and our forums are now closed.

Open Support Ticket