Critical error when trying to authenticate GA credentials

This topic contains 4 replies, has 3 voices, and was last updated by  Thomas 4 years, 3 months ago.

We have moved to a support ticketing system and our forums are now closed.

Open Support Ticket
  • Author
    Posts
  • #539674

    Thomas
    Full Member
    Post count: 9

    Tried authenticating GA in GEO and got a critical error

    When seeking help with this issue, you may be asked for some of the following information:
    WordPress version 5.4
    Current theme: Lisitmia – Child Theme (version 1)
    Current plugin: GeoDirectory Google Analytics (version 2.0.0.5)
    PHP version 7.4.2

    Error Details
    =============
    An error of type E_ERROR was caused in line 45 of the file /home/lgfhij32bieh/public_html/wp-content/plugins/geodir-google-analytics/includes/admin/class-geodir-google-analytics-api.php. Error message: Uncaught Error: Class ‘Google_Service_Analytics’ not found in /home/lgfhij32bieh/public_html/wp-content/plugins/geodir-google-analytics/includes/admin/class-geodir-google-analytics-api.php:45
    Stack trace:
    #0 /home/lgfhij32bieh/public_html/wp-content/plugins/geodir-google-analytics/includes/admin/settings/class-geodir-settings-analytics.php(220): GeoDir_Google_Analytics_API->__construct()
    #1 /home/lgfhij32bieh/public_html/wp-content/plugins/geodir-google-analytics/includes/admin/settings/class-geodir-settings-analytics.php(186): GeoDir_Settings_Analytics::get_analytics_accounts()
    #2 /home/lgfhij32bieh/public_html/wp-content/plugins/geodir-google-analytics/includes/admin/settings/class-geodir-settings-analytics.php(120): GeoDir_Settings_Analytics::analytics_accounts()
    #3 /home/lgfhij32bieh/public_html/wp-content/plugins/geodirectory/includes/admin/settings/class-geodir-settings-page.php(139): GeoDir_Settings_Analytics->get_settings(”)
    #4 /home/lgfhij32bieh/public_html/wp-content/plugins/geodirectory/includes/a

    #539727

    Kor
    Moderator
    Post count: 16516

    Hi Thomas,

    Thanks for your post. It could be a temporary issue with the API. Could you try again and if the issue persists, kindly share your Website WP admin access in private reply and we’ll check this out for you asap!

    #540408

    Thomas
    Full Member
    Post count: 9
    This reply has been marked as private.
    #540448

    Alex Rollin
    Moderator
    Post count: 27815
    This reply has been marked as private.
    #540450

    Thomas
    Full Member
    Post count: 9
    This reply has been marked as private.
Viewing 5 posts - 1 through 5 (of 5 total)

We have moved to a support ticketing system and our forums are now closed.

Open Support Ticket