GD CPT Archives not changing language

This topic contains 6 replies, has 3 voices, and was last updated by  jotomas 1 year, 9 months ago.

We have moved to a support ticketing system and our forums are now closed.

Open Support Ticket
  • Author
    Posts
  • #531350

    jotomas
    Full Member
    Post count: 802

    Hello,

    I have four GD CPT Archives in the main menu options.

    Two of them (“Menjar i Beure” and “Serveis”) correctly switch language when using the language selector and show the CPT Archive page in the new language, but the other two “Shopping” and “Activitats”) show the home page in the new language instead the CPT Archive page.

    I have tried with both GD CPT Archives and Custom Link menu (which I left set) options with the same results.

    I look forward to your news.

    Thank you very much once again for your help.

    Best regards.

    #531357

    Alex Rollin
    Moderator
    Post count: 27815

    We can take a look, please share details in a private reply.

    #531361

    jotomas
    Full Member
    Post count: 802
    This reply has been marked as private.
    #531515

    Kiran
    Moderator
    Post count: 7069

    Hi jotomas,

    This is because there is no listings are added under Shopping & Activitats. I have added one listing under Shopping and links are working fine for Shopping menu.

    Kiran

    #531526

    jotomas
    Full Member
    Post count: 802

    Hi Kiran,

    Thank you very much for your reply.

    Ok. I see.

    I have also added an Activitats listing and now it works fine too.

    However, I do not think that this would be the right behaviour. Should not it be showing the archive page in the translated language with the “No listings found” message like it does for the main language, instead showing the home page in the translated language?

    I look forward to your news.

    Thank you very much once again for your help.

    Best regards.

    #531529

    Kiran
    Moderator
    Post count: 7069

    Hi jotomas,

    It looks like this is a default behaviour from WPML, because that language switcher menu is generated by WPML.

    I found someone has reported similar issue at WPML support. See https://wpml.org/forums/topic/language-switcher-does-not-work-for-empty-cpt-archives/

    Regards,
    Kiran

    #531535

    jotomas
    Full Member
    Post count: 802

    Hi Kiran,

    Thank you very much for your reply.

    Ok, I have opened a support ticket with WPML. I will let you know what they say.

    Thank you very much once again for your help.

    Best regards.

Viewing 7 posts - 1 through 7 (of 7 total)

We have moved to a support ticketing system and our forums are now closed.

Open Support Ticket