GD Loop not showing in Search Page on initial load

This topic contains 5 replies, has 2 voices, and was last updated by  gowrann 1 year, 7 months ago.

We have moved to a support ticketing system and our forums are now closed.

Open Support Ticket

Tagged: 

  • Author
    Posts
  • #541134

    gowrann
    Expired Member
    Post count: 39

    Hi,

    My GD Loop is not showing on the Search page on initial page load – only when a search is done then the listings show.

    My search page shortcode is…

    [gd_notifications]
    [gd_search]
    [gd_loop layout=0]
    [gd_loop_paging]
    

    How can I get the loop to show on the initial load.

    Thanks

    #541136

    Alex Rollin
    Moderator
    Post count: 27815

    It will not show any results on initial load.

    #541137

    gowrann
    Expired Member
    Post count: 39

    Oh I see, is it possible to show all listings below the search?

    #541150

    gowrann
    Expired Member
    Post count: 39

    Ok I see that I need to be on the cpt archive page to have all the listings display

    #541154

    Alex Rollin
    Moderator
    Post count: 27815

    Right like /places/

    I recommend you link to search with a search results URL, if you need a link to the search page.

    https://wpgeodirectory.com/docs-v2/templates/

    #541156

    gowrann
    Expired Member
    Post count: 39

    Ok yes I see using a Custom Link for the search

    /search/?geodir_search=1&stype=gd_place&s=+&snear=&sgeo_lat=&sgeo_lon=
Viewing 6 posts - 1 through 6 (of 6 total)

We have moved to a support ticketing system and our forums are now closed.

Open Support Ticket