Supreme theme listing avatar

This topic contains 14 replies, has 4 voices, and was last updated by  Giri 3 years, 7 months ago.

Tagged: ,

  • Author
    Posts
  • #396528

    Joy
    Buyer
    Post count: 1076

    Hello, on the Supreme theme when a listing is created by admin, the avatar that is showing for the listing owner is the facebook mystery avatar. How can I change that?

    Thank you.

    #396550

    Kor
    Moderator
    Post count: 16516

    Hi Joy,

    Could you give “userswp plugin” a try and see if it’s what you’re looking for? https://userswp.io/

    Thanks!

    #396551

    Joy
    Buyer
    Post count: 1076

    Hello I am using userswp. But the listing avatar only changes if the listing is claimed.

    #396553

    Kor
    Moderator
    Post count: 16516

    Hi Joy,

    Do you mean you want to change this even when the listing is not claimed? http://prntscr.com/gnceyo . If you are, check out this option http://prntscr.com/gncfcn and see if it helps.

    Thanks!

    #396613

    Paolo
    Site Admin
    Post count: 31205

    Upload an avatar for the Admin via UsersWP. If now you see the facebook avatar it is because you synced the admin account via social login…

    #396643

    Joy
    Buyer
    Post count: 1076

    The avatar settings in WordPress does not help. The image that is being shown in the unclaimed listings in the supreme theme is from the theme – not wordpress.

    @paolo, as I said, it works for a claimed listing. If a listing is created, then claimed(or claiming is disabled for a particular type), then the admin avatar appears. Otherwise, if the listing is not claimed, another image is shown. You can see it here: https://wpgeo.directory/supreme-directory/places/united-states/california/san-francisco/attractions/alcatraz-island/

    How do I change that image? Thank you.

    #396760

    Giri
    Expired Member
    Post count: 3155

    Hi Joy,

    When you connect to facebook it insert the facebook avatar image as avatar.

    So you mean you would like to exclude the default facebook avatar?

    #396761

    Giri
    Expired Member
    Post count: 3155

    If you are talking about this avatar, then you need to replace that image with your default avatar in supreme.

    This is the path

    /wp-content/themes/supreme-directory/images/gravatar2.png

    #396818

    Joy
    Buyer
    Post count: 1076

    Thanks @giri, this is the image I was talking about.

    Is there a function that I can use to change this instead? It seems that it will be reset with each update using this method.

    Thank you.

    #396822

    Joy
    Buyer
    Post count: 1076

    I found this post. I’ll give this a try and let you know if it works:
    https://wpgeodirectory.com/support/topic/lost-gravatar/#post-383593

    #396823

    Joy
    Buyer
    Post count: 1076

    Oops, nevermind. I see that this is for claimed listings…

    #396953

    Giri
    Expired Member
    Post count: 3155

    Hi Joy,

    If you are talking about this image,

    /wp-content/themes/supreme-directory/images/gravatar2.png

    then your only option right now is to overwrite the image.

    I can add a filter in the next version to override that image via hooks.

    In the mean time please use overwrite option.

    Thanks

    #396955

    Giri
    Expired Member
    Post count: 3155

    Ok I just modified the code.

    Please make these changes and you should be fine.

    File: /Users/giri/Sites/wordpress/wp-content/themes/supreme-directory/inc/geodirectory-compatibility.php

    In line 821 you will see this line.
    https://github.com/mistergiri/supreme-directory/blob/master/inc/geodirectory-compatibility.php#L821

    
    
    
    $entry_author = '<img src="'.get_stylesheet_directory_uri() . "/images/gravatar2.png".'"  height="100" width="100">';

    Replace that line with these two lines.

    
    
    if (!defined('SD_DEFAULT_GRAVATAR_IMAGE')) define('SD_DEFAULT_GRAVATAR_IMAGE', get_stylesheet_directory_uri() . "/images/gravatar2.png");
    $entry_author = '<img src="'.SD_DEFAULT_GRAVATAR_IMAGE.'"  height="100" width="100">';

    Now all you have to do is that add this line in your wp-config.php file

    define('SD_DEFAULT_GRAVATAR_IMAGE', 'http://your image url here');

    Thanks

    #397010

    Joy
    Buyer
    Post count: 1076

    Thank you! It worked. 🙂

    #397228

    Giri
    Expired Member
    Post count: 3155

    You are welcome 🙂

Viewing 15 posts - 1 through 15 (of 15 total)

The topic ‘Supreme theme listing avatar’ is closed to new replies, this may be for inactivity, please open a new topic if you have a similar question.