New user experiences

This topic contains 24 replies, has 5 voices, and was last updated by  Stiofan O’Connor 3 years, 6 months ago.

We have moved to a support ticketing system and our forums are now closed.

Open Support Ticket
  • Author
    Posts
  • #425267

    Tom Eranary
    Expired Member
    Post count: 37

    I have been playing around with the new GeoDirectoy 2.0.0.9 beta as a first time user. It’s definitely one of the more impressive WordPress plugins, with lots of promise and attention to detail. Also the wizard on first install is very nice.

    I do have some questions and remarks. Note that I did my testing on a brand new WP 4.9.5 with only GeoDirectory 2, WPusers and the Supreme theme (although all errors also occurred with the default theme) and no customisations. I tested all these issues on both Safari and Chrome for Mac:

    1. Neither the location page or the place detail pages can show maps. They are grey boxes with a spinning wheel as seen here: https://aroonasoftware.com/geotest/?page_id=7. On the Add location page, maps work fine.
    2. When visitors add a listing and define a URL, they are asked to include http:// if they didn’t. This should be done automatically.
    3. When visitors add a facebook or twitter link to a listing, they need to specify the full URL. If they only specify the facebook or twitter name, the link should be composed automatically.
    4. There’s no auto-complete when filling out addresses. Can this be enabled?
    5. The Shortcode [gd_listings] shows the description of places, but doesn’t respect text paragraphs, instead everything is put in one text block as seen here: https://aroonasoftware.com/geotest/?page_id=7
    6. Thumbnails of images of places are stretched out, not respecting the aspect ratio
    7. the widescreen slider in the Supreme theme doesn’t show the images of the place (but I guess that’s because the theme is not compatible yet)
    8. It seems users can leave unlimited reviews on a place. Is this intentional?
    9. And an issue related to WPUsers: the user profile page My Account is not accessible due to too many redirects (http error 500) when logged in. When not logged in the user detail page redirects to the homepage.

    As I said, I didn’t do any customisations besides setting up all the bare essentials.

    #425332

    Stiofan O’Connor
    Site Admin
    Post count: 22954

    Hi Tom,

    Thank you for taking the time to test and report, it is very much appreciated, let me try and answer each point below:

    As our blog post explains the Supreme theme and the Directory Starter theme have JS conflicts from GDv1 and should be avoided when testing, this might account for some of the problems. Try testing with another theme, i am using “Primer” free theme from wp.org.

    1. likely theme.
    2. This is HTML5 validation, we would not know if we should add http or https and that could be critical, its best the user adds this, or they can simple copy/paste.
    3. I think its bets they copy/past the url, there are many situations where we could mess it up rather then help.
    4. This is a feature of the Multilocations addon, in core you are simply entering the street name.
    5. This is somewhat a bug and has been changed in next ver.
    6. Theme related.
    7. Theme related.
    8. Yes.
    9. UWP has not been fully tested yet, but thanks for letting us know.

    Try another theme 🙂

    Thanks,

    Stiofan

    #425338

    Bart Verheecke
    Free User
    Post count: 2

    Hi, I switched to another theme and all issues above are still present except for 6 and 7.

    Regarding issue 5, will you provide a cut-off point as long descriptions would mess up the listings?

    Issue 9 is weird as it even occurs when the Geodirectory beta is deactivated. Clicking any dummy user causes the issue: https://aroonasoftware.com/geotest/?page_id=19

    #425398

    Alex Rollin
    Moderator
    Post count: 27815

    Thanks for the feedback Bart!

    If you find more issues with GDV2, great.
    We have a couple theme recommendations in the setup docs for the Beta, to limit the focus to GDV2 and what we are working on now.
    Check it and and do let us know if you find bugs!

    https://wpgeodirectory.com/docs-v2/geodirectory/beta/

    #425402

    Bart Verheecke
    Free User
    Post count: 2

    ok, no problem. I have now switched to the Primer theme.

    Issue 1 (grey maps with spinning wheel) are still present, as is issue 9 with the user profiles not showing up.

    https://aroonasoftware.com/geotest/?page_id=7
    https://aroonasoftware.com/geotest/?page_id=19

    #425452

    Alex Rollin
    Moderator
    Post count: 27815

    Hello!

    1# Map issue – I cannot recreate that. Could you share WP Admin for the site, or tell me the steps to recreate the issue?

    2# Profile – I saw the problem there too, but I cannot reproduce it.

    I recommend you try to recreate on a fresh install

    #425473

    akia
    Buyer
    Post count: 35

    It might also be worth pointing out that if you visit Toms site on a mobile the listings look terrible. Not sure whether it’s a GD issue or theme issue but thought I’d mention it.

    Screen shot attached.

    #425474

    akia
    Buyer
    Post count: 35

    Oh it won’t let me attached it. Here’s it in my dripbkx account.

    Screen shot

    #425493

    akia
    Buyer
    Post count: 35
    #425579

    Stiofan O’Connor
    Site Admin
    Post count: 22954

    For the maps i see our api ajax requests are going to 404, try setting the WP permalinks to something pretty and not the ID.

    Stiofan

    #426183

    Tom Eranary
    Expired Member
    Post count: 37

    @stiofan : I can confirm that changing the Permalinks fixes the grey maps issue. Maybe it’s a good idea to check for that in the First-Time wizard, so that this issue is avoided?

    @Matthew Blackburn: You’re right. Listings on mobile devices are messed up. I have switched to Primer, Divi and Supreme Directory themes and they all more or less have the same issue. I assume this will be fixed in a later GD beta?

    #426222

    Stiofan O’Connor
    Site Admin
    Post count: 22954

    Hi Tom,

    The map issue with permalinks has been fixed and will be in the next release.

    Mobile CSS is currently being worked on and will be improved in an upcoming release 🙂

    Thanks,

    Stiofan

    #426773

    Tom Eranary
    Expired Member
    Post count: 37

    hi, I have reinstalled the latest beta 11 and happy to report all my previous issues have been resolved (apart from the theme related onces obviously). I did notice some other issues:

    1) In the welcome wizard you can populate the DB with fake places. The GUI gives the impression this process will continue in the background if you press next. But it doesn’t. So maybe the next button should be unavailable until the process has finished.

    2) The feature to retrieve the current user position does not work. I tried it to get driving directions and always get a “your location is unknown” after giving my browser permission to get my location. I tried this on both Safari and Chrome for mac. see screenshot.

    3) I notice the option to get the user location is not available in Location Search (only for driving directions and adding listings). I assume this feature is enabled with the multi-locations plugin? Does this plugin allow to use the whole world as one region, or do you need to activate separate regions?

    4) It’s currently unclear how the Ninja forms integration works without reading your blog post. I did add a ninja form manually to a place description using a shortcode. Is that how it works, adding it manually to each place’s description? Or am I missing something?

    5) I’m unsure where the default listing image is used? Maybe that’s theme dependent but i don’t see it anywhere in the frontend. (see screenshot)

    I hope you find my comments useful.

    #426794

    Alex Rollin
    Moderator
    Post count: 27815

    Hello Tom,

    I do find your comments useful! Thank you so much for your reports!

    I will be checking on your comments a bit later today along with the rest of the team.

    Thanks for your feedback!

    #427997

    Tom Eranary
    Expired Member
    Post count: 37

    Hi, did you get the chance yet to look into the issues I reported yet. Thanks

Viewing 15 posts - 1 through 15 (of 25 total)

We have moved to a support ticketing system and our forums are now closed.

Open Support Ticket